Translate

Captive Portal Authentication with MikroTik Router as The End Devices

Captive Portal adalah sebuah halaman web yang ditampilkan saat seorang user baru terkoneksi ke sebuah jaringan dan ingin mengakses resource yang dimiliki dari jaringan tersebut (contoh: Internet) atau pada mikrotik hal ini sering kali disebut hotspot namun sebagai informasi tambahan saja, hal ini tidak hanya di mikrotik.
















Hari ini, 7 Juli 2018 saya mendapatkan case ketika login hotspot dengan perangkat saya langsung (handphone & laptop) saya mendapatkan IP Public langsung dan tidak ada NAT untuk ke internet sehingga semua orang dari seluruh dunia bisa mengakses perangkat saya secara langsung dan saya sendiri merasa tidak aman dan nyaman karena hal tersebut :)



untuk mengatasi hal ini, untungnya dalam perjalanan kali ini saya membawa router mini saya yang bertipe RB931-2nD a.k.a. hAP-mini agar IP Public terpasang pada router tersebut dan semua end-devices saya menggunakan ip private saja namun saya terkendala dikarenakan router mikrotik tidak bisa melakukan hotspot authentication by browser dan begitupun apa yang dikatakan oleh tim support mikrotik pada tanggal 26 Juni 2017 lalu


dan untuk mengatasi hal ini saya coba dari laptop saya untuk disconnect wifi lalu reconnect kembali dan terpantau tidak melakukan authentication by web browser kembali dan bisa saya simpulkan bahwa sistem dari captive portal yang ada ini juga mendukung authentication by mac cookies karena ketika saya reconnect pada wifi ini, saya tidak perlu melakukan authentication by web atau buka browser maka dari itu saya coba hal ini kembali menggunakan router mikrotik dengan meng-clone mac address yang digunakan laptop saya untuk authentication sebelumnya dan untuk cara mengubahnya sendiri cukup mudah
/interface wireless set [find name="wlan1"] mac-address="00:00:00:00:00:00"
note: untuk wlan1 bisa disesuaikan dengan interface wlan yang ingin digunakan dan untuk mac-address yang saya isi 00:00:00:00:00:00 juga bisa disesuaikan dengan mac address laptop yang anda gunakan untuk authentication sebelumnya dan setelah hal ini, anda juga harus set interface wlan tersebut menjadi mode client dengan cara:
/interface wireless set [find name="wlan1"] mode=station ssid=hotspot band=2ghz-b/g/n
note: untuk wlan1 bisa disesuaikan dengan interface wlan yang ingin digunakan dan untuk mode wajib station karena interface tersebut akan kita fungsikan sebagai client dan untuk parameter ssid dan band bisa disesuaikan dengan settingan yang ada di AP (harus sama)


dan jika sudah, saat ini bisa setting IP dan karena ini hotspot, biasanya ada DHCP dan untuk dhcp-client bisa di set seperti ini
/ip dhcp-client add interface=wlan1 disabled=no 
interface wlan1 bisa disesuaikan dengan interface wlan yang disetting sebelumnya dan parameter disabled=no artinya kita ingin mengfungsikan settingan yang kita buat

lalu untuk memverifikasi semua settingan diatas, kita bisa check apakah kita mendapatkan IP atau tidak dan router tersebut bisa internetan atau tidak dengan command traceroute ke website yang kita tuju, untuk pada artikel ini saya coba untuk traceroute ke detik.com


















well done, router bisa internetan, dengan ini kita tinggal mendistribusikan kembali koneksi internet yang kita dapatkan dengan cara masing masing dan tentunya juga menggunakan ip private sehingga perangkat yang kita memiliki tidak terbuka lebar di internet dan tentunya 1 user tersebut bisa dipakai di banyak perangkat :)

sekian tulisan saya yang ala kadarnya dan acak acakan dan juga tidak EYD dikala gabut dan kebetulan lagi ada mood untuk nulis

1 Comment: