Translate

OSPF Redistribute Static

Objective:

  1. Membuat Routing OSPF Multi-Area
  2. Loopback Router MikroTik-5 Tidak Di Advertise Dalam OSPF
  3. Router MikroTik-4 Membuat Static Route Kearah 5.5.5.5
  4. Router MikroTik-4 Me-Redistribute Static Route Kearah 5.5.5.5
Goal:
  1. Semua IP Loopback Bisa Di PING
1. MikroTik-1
/interface bridge
add name=lo
/routing ospf instance
set [ find default=yes ] router-id=1.1.1.1
/ip address
add address=12.12.12.1/30 interface=ether1 network=12.12.12.0
add address=1.1.1.1 interface=lo network=1.1.1.1
/routing ospf network
add area=backbone network=12.12.12.0/30
add area=backbone network=1.1.1.1/32
/system identity
set name=R1
2. MikroTik-2
/interface bridge
add name=lo
/routing ospf area
add area-id=0.0.0.1 name=area1
/routing ospf instance
set [ find default=yes ] router-id=2.2.2.2
/ip address
add address=12.12.12.2/30 interface=ether1 network=12.12.12.0
add address=2.2.2.2 interface=lo network=2.2.2.2
add address=23.23.23.1/30 interface=ether2 network=23.23.23.0
/routing ospf network
add area=backbone network=12.12.12.0/30
add area=backbone network=2.2.2.2/32
add area=area1 network=23.23.23.0/30
/system identity
set name=R2
3. MikroTik-3
/interface bridge
add name=lo
/routing ospf area
add area-id=0.0.0.1 name=area1
/routing ospf instance
set [ find default=yes ] router-id=3.3.3.3
/ip address
add address=23.23.23.2/30 interface=ether1 network=23.23.23.0
add address=34.34.34.1/30 interface=ether2 network=34.34.34.0
add address=3.3.3.3 interface=lo network=3.3.3.3
/routing ospf network
add area=area1 network=23.23.23.0/30
add area=area1 network=34.34.34.0/30
add area=area1 network=3.3.3.3/32
/system identity
set name=R3
4. MikroTik-4
/interface bridge
add name=lo
/routing ospf area
add area-id=0.0.0.1 name=area1
/routing ospf instance
set [ find default=yes ] redistribute-static=as-type-1 router-id=4.4.4.4
/ip address
add address=34.34.34.2/30 interface=ether1 network=34.34.34.0
add address=4.4.4.4 interface=lo network=4.4.4.4
add address=45.45.45.1/30 interface=ether2 network=45.45.45.0
/ip route
add distance=1 dst-address=5.5.5.5/32 gateway=45.45.45.2

/routing ospf network
add area=area1 network=34.34.34.0/30
add area=area1 network=4.4.4.4/32
add area=area1 network=45.45.45.0/30
/system identity
set name=R4
5. MikroTik-5
/interface bridge
add name=lo
/ip address
add address=45.45.45.2/30 interface=ether1 network=45.45.45.0
add address=5.5.5.5 interface=lo network=5.5.5.5
/ip route
add distance=1 gateway=45.45.45.1
/system identity
set name=R5

Routing Table 
Terlihat Ada Perbedaan Pada Routing Table Kearah 5.5.5.5 ;)

LAB 04 - eBGP multihop

1. MikroTik-1
/interface bridge
add name=lo
add name=network
/routing bgp instance
set default as=100 router-id=1.1.1.1
/ip address
add address=12.12.12.1/30 interface=ether1
add address=1.1.1.1 interface=lo
add address=100.100.100.100 interface=network
/ip route
add distance=1 dst-address=2.2.2.2/32 gateway=12.12.12.2
/routing bgp network
add network=100.100.100.100/32
/routing bgp peer
add multihop=yes name=peer1 remote-address=2.2.2.2 remote-as=200 update-source=lo
/system identity
set name=R1
2. MikroTik-2
/interface bridge
add name=loopback
add name=network
/routing bgp instance
set default as=200 router-id=2.2.2.2
/ip address
add address=12.12.12.2/30 interface=ether1
add address=2.2.2.2 interface=lo
add address=200.200.200.200 interface=network
/ip route
add distance=1 dst-address=1.1.1.1/32 gateway=12.12.12.1
/routing bgp network
add network=200.200.200.200/32
/routing bgp peer
add multihop=yes name=peer1 remote-address=1.1.1.1 remote-as=100 update-source=lo
/system identity
set name=R2

LAB 03 - eBGP on Physical Interface

1. MikroTik-1
/interface bridge
add name=lo
/routing bgp instance
set default as=100
/ip address
add address=12.12.12.1/30 interface=ether1
add address=1.1.1.1 interface=lo
/routing bgp network
add network=1.1.1.1/32
/routing bgp peer
add name=peer1 remote-address=12.12.12.2 remote-as=200
/system identity
set name=R1
2. MikroTik-2
/interface bridge
add name=loopback
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default as=200
/ip address
add address=12.12.12.2/30 interface=ether1 network=12.12.12.0
add address=2.2.2.2 interface=loopback network=2.2.2.2
/routing bgp network
add network=2.2.2.2/32
/routing bgp peer
add name=peer1 remote-address=12.12.12.1 remote-as=100
/system identity
set name=R2



LAB 02 - iBGP on Loopback Interface

1. MikroTik-1
/interface bridge
add name=lo
add name=network
/routing bgp instance
set default as=100 router-id=1.1.1.1
/ip address
add address=1.1.1.1 interface=lo
add address=12.12.12.1/30 interface=ether1
add address=10.10.10.10 interface=network
/ip route
add distance=1 dst-address=2.2.2.2/32 gateway=12.12.12.2
/routing bgp network
add network=10.10.10.10/32
/routing bgp peer
add name=peer1 remote-address=2.2.2.2 remote-as=100 update-source=lo
/system identity
set name=R1
2. MikroTik-2
/interface bridge
add name=lo
add name=network
/routing bgp instance
set default as=100 router-id=2.2.2.2
/ip address
add address=12.12.12.2/30 interface=ether1
add address=2.2.2.2 interface=lo
add address=20.20.20.20 interface=network
/ip route
add distance=1 dst-address=1.1.1.1/32 gateway=12.12.12.1
/routing bgp network
add network=20.20.20.20/32
/routing bgp peer
add name=peer1 remote-address=1.1.1.1 remote-as=100 update-source=loopback
/system identity
set name=R2

LAB 01 - iBGP on Physical Interface

1. MikroTik-1
/interface bridge
add name=lo
/routing bgp instance
set default as=100
/ip address
add address=12.12.12.1/30 interface=ether1
add address=1.1.1.1 interface=lo
/routing bgp network
add network=1.1.1.1/32
/routing bgp peer
add name=peer1 remote-address=12.12.12.2 remote-as=100
/system identity
set name=R1
2. MikroTik-2
/interface bridge
add name=lo
/routing bgp instance
set default as=100
/ip address
add address=12.12.12.2/30 interface=ether1
add address=2.2.2.2 interface=lo
/routing bgp network
add network=2.2.2.2/32
/routing bgp peer
add name=peer1 remote-address=12.12.12.1 remote-as=100
/system identity
set name=R2

Great Experience on Olimpiade Jaringan MikroTik-APJII 2016


29 September 2016 - 14 Oktober 2016
Ya dalam waktu tersebut saya mengalami banyak hal, Terutama pada saat tanggal 29 September, 12 Oktober dan 14 Oktober saya mengalami hal hal yang menegangkan dan "ngos ngosan" pada tanggal 14 Oktober saat berdiri didepan ribuan orang untuk mempresentasikan DNS Spoofing

Oke, mungkin akan saya mulai dari Tanggal 29 September, bagaimana saya mempersiapkan diri dan saat saya menghadapi 40 soal tertulis dan 5 soal wajib maupun 10 soal rebutan saat itu
Yang pasti cukup bikin "deg degan" bukan "ngos ngosan" saat tanggal 14 Oktober hehehe, dikarenakan teman - teman saya sudah menunggu di Final (Pak Teddy Yuliswar dan Melki Mario Gulo) dan juga disaat penyisihan saya menghadapi teman saya sendiri yang bisa dibilang belajar pun kami bersama, Ya hampir semua sekolah yang masuk ke Tahap 2 itu saya mengenal mereka

Siang Hari, tepatnya jam 1 siang saya bersyukur karena masuk Tahap 2, namun beberapa teman saya gugur, jadi sedih dan senang bercampur hehehhe, saya pun langsung masuk karantina untuk persiapan Tahap 2 dan saya ingat sekali saya ditemani oleh beberapa teman saya dan seorang panitia saat itu yang bernama Aji Diyantoro, saya masih ingat apa katanya yaitu Semuanya Akan c**t Pada Waktunya, Ya namun abaikan saja, beliau hanya bercanda saat itu agar suasana tidak terlalu tegang hehehe

Siang menjelang Sore Hari, tepatnya jam 14:45 Saya mulai bertarung dengan SMK N 1 Cimahi (Pak Dodi Permana) yang saat itu bertemu saya saat saya Training + Exam MTCNA di Tigaraksa dengan "Kakek Guru" dan juga saya bertarung dengan SMK Fadris Tasikmalaya yang kenal dengan Kepala Sekolah SMK Taruna Bhakti Depok (Bapak Ramadin Tarigan), Ok setelah kami bertiga Bertanding hasil akhir pun keluar, Saya mendapatkan Score 130 dan disusul oleh SMK N 1 Cimahi dengan Score 30 dan SMK Fadris Tasikmalaya dengan Score 20, alhasil saya berhasil maju ke Babak Final, Terima Kasih kepada kawan kawan dan guru yang men-support saya selama ini :) Perjuangan saya selama 3 Hari yang Menginap Disekolah, Makan Disekolah, Tidur Disekolah, Kaga Mandi terbalaskan pada Tanggal 29 September ini :)




Oke, Berlanjut pada Tanggal 12 Oktober 2016, tepatnya Babak Final, Dibabak Final ini ya Tepatnya Sebelum Babak Final ini cukup banyak juga yang saya lalui terutama saat saya bertemu dengan Pak Onno W. Purbo, Pak Johar Alam Rangkuti,  Pak Marcelus Ardiwinata, Pak Teddy Mantoro, Pak Adiatmo Rahardi, Pak Dadang Setiawan, Pak Gildas Deograt,  Ya sangat banyak sekali Ilmu yang berikan saat ITCamp Tanggal 1 - 2 Oktober, selain ilmu saya bisa berkenalan dengan mereka semua :)


Setelah ITCamp saya pun di "Karantina" lagi didalam sekolah mulai tanggal 5 Oktober - Babak Final, saat Karantina ini pun saya mendapatkan beberapa dukungan yang sangat besar dan bermanfaat dari mas(ter) M. Danu Wiyoto yang memberikan fasilitas tempat dan meminjamkan RouterBoard milik beliau dan terutama anak - anak mondok dari Best-Path Networks (Rivaldo Ibrahim, Adit Ilhandhi, Ratna Swastika, Rifki a.k.a Bejo, Mas Imam) Yang membantu saya untuk "ngoprek" BGP dan OSPF pada MikroTik yang digabungkan dengan Cisco 1841 (See More) & mas(ter) Faisal Reza yang membantu saya semalam sebelum perlombaan dan menutupi kekurangan saya dalam Traffic Control, Bandwith Management, HTB dan Packet Flow, yang disalutkan dari beliau adalah beliau rela datang jauh jauh dari Sukabumi, Membatalkan Meeting dan Mengajari Saya teman 1 Team saya sampai tengah malam Dan tidak lupa Pak Teddy Yuliswar yang mengadakan belajar bareng lewat Team Viewer dengan Om Wenas Ongkowinoto, ya waktu itu saya mendapatkan pengajaran tentang BGP dan besoknya juga Saya Mengikuti Webinar tentang BGP on MikroTik oleh GLC Network dengan Trainer Pak Achmad Mardiansyah

Oke, 12 Oktober 2016 pun akhirnya tiba, saya berangkat dengan Pak Faisal Reza dari Cikini setelah belajar hingga "Tengah Malam" ya kami pun Tiba Disana dan tidak langsung masuk dikarenakan Pak Agung terjebak Macet dengan Pak Roby, namun disaat - saat terakhir mereka tiba :) tidak lama setelah mereka tiba pun, perlombaan langsung dimulai setelah mendengar Testimoni tentang Olimpiade oleh Seluruh Finalist, Tahap pertama Final ini cukup menegangkan dan mengagetkan karena menggunakan 1 Router dan yang paling ngeselin hehehe dan "deg degan" adalah ketika pembacaan Sekolah yang Masuk ke Tahap Selanjutnya kami disebut Paling Terakhir, Ya Namun tidak masalah saya bersyukur karena masih bisa masuk ke Tahap Selanjutnya, Oh iya kami juga sempat mendapatkan "IP Salah" yang tidak sesuai dengan nomor kami, Tapi dengan cepat Panitia (Pak Novan) membantu kami dengan cepat

Tahap 4, Tahap ini sangat menguras Pikiran karena kami harus menguras Logika dan Pikiran kami dimana kita harus menghubungkan 2 network (Bridging) tanpa adanya client, Ditahap 4 ini kami difokuskan untuk DHCP Relay, Routing dan Tunneling, Bayangkan ada 4 Network dengan 2 Router dan 2 Client (Laptop Kami) alhasil kita hanya membuat "Loopback Interface" Untuk Network Siluman yang tidak ada client :) Tahap ini benar benar menggantung nasib kami untuk masuk kedalam 3 Besar namun berkat bantuan dari Para Guru yang membantu saya, saya pun bisa melewati dan mengerjakan semua soal di Tahap 4 ini walaupun dengan waktu "pas - pasan"

Tahap 5, Tahap ini SMK Taruna Bhakti Depok sudah mencapai 3 Besar dan kami bertarung dengan SMK N 2 Surakarta dan SMK N 1 Cerme Gresik, Ditahap ini cukup menengangkan karena soal - soal Pertanyaan yang diberikan sangatlah Advance dan Posisi saya saat itu Kedinginan dan Lapar Alhasil disaat terakhir saya Gemetar dan tangan saya berada didekat bel dan berhasil melakukan aksi #SalahPencet hahaha

Thanks To My Beloved Teacher & Mentor

OSPF Network Summarization over PPTP Tunnel & EoIP Tunnel

OSPF Network Summarization over PPTP Tunnel & EoIP Tunnel
Objective:

  1. Membuat Tunnel PPTP antara 2 ISP
  2. Membuat Layer-2 Connection Antara 2 CPE
  3. Distribusi IP Ke CPE Menggunakan /32 Dengan PPPoE
  4. Routing Pada PPTP Menggunakan OSPF Yang Networknya Di Summarization

Goal:
  1. Antar ISP Bisa PING
  2. Antar CPE Bisa PING Tapi Tidak Bisa PING Ke ISP
  3. Antar Client Bisa PING Tapi Tidak Bisa PING Ke ISP

1. INTERNET
/ip address
add address=1.1.1.1/30 interface=ether1 network=1.1.1.0
add address=2.2.2.1/30 interface=ether2 network=2.2.2.0

2. ISP-1
/ppp profile
add local-address=172.16.1.1 name=pptp-profile remote-address=172.16.1.10
add address-list=no local-address=10.10.10.1 name=pppoe remote-address=10.10.10.10
/interface pppoe-server server
add default-profile=pppoe disabled=no interface=ether2
/interface pptp-server server
set default-profile=pptp-profile enabled=yes
/ip address
add address=1.1.1.2/30 interface=ether1 network=1.1.1.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether1
/ip route
add distance=1 gateway=1.1.1.1
/ppp secret
add name=pptp password=pptp profile=pptp-profile service=pptp
add name=ppp@isp1.net password=pppoe service=pppoe
/routing ospf network
add area=backbone network=172.16.1.0/28
add area=backbone network=10.10.10.0/28

3. ISP-2
/interface pptp-client
add add-default-route=yes connect-to=1.1.1.2 default-route-distance=1 disabled=no name=pptp-out1 password=\
    pptp user=pptp
/ppp profile
add local-address=20.20.20.1 name=pppoe remote-address=20.20.20.10
/interface pppoe-server server
add default-profile=pppoe disabled=no interface=ether2
/ip address
add address=2.2.2.2/30 interface=ether1 network=2.2.2.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether1
/ip route
add distance=1 gateway=2.2.2.1
/ppp secret
add name=ppp@isp2.net password=pppoe
/routing ospf network
add area=backbone network=172.16.1.0/28
add area=backbone network=20.20.20.0/28

4. CPE-1
/interface bridge
add name=eoip-bridge
/interface pppoe-client
add add-default-route=yes default-route-distance=1 disabled=no interface=ether1 name=pppoe-out1 password=\
    pppoe use-peer-dns=yes user=ppp@isp1.net
/interface eoip
add name=eoip1 remote-address=20.20.20.10 tunnel-id=100
/interface bridge port
add bridge=eoip-bridge interface=eoip1
add bridge=eoip-bridge interface=ether2

5. CPE-2
/interface bridge
add name=eoip-bridge
/interface pppoe-client
add add-default-route=yes default-route-distance=1 disabled=no interface=ether1 name=pppoe-out1 password=\
    pppoe use-peer-dns=yes user=ppp@isp2.net
/interface eoip
add name=eoip1 remote-address=10.10.10.10 tunnel-id=100
/interface bridge port
add bridge=eoip-bridge interface=eoip1
add bridge=eoip-bridge interface=ether2

6. Client
Client-1 = 192.168.1.10/24
Client-2 = 192.168.1.20/24

The Great Journey to Semarang & ID-Networkers Networking Competition




IPv6 Static Route


Singkat Cerita mau nyoba OSPFv3 tapi bingung karena gak ada kolom networks seperti OSPFv2 (yang biasa)

Yaudah deh nyobain static route aja hahahaha

1. Config IP diantara MikroTik agar bisa terhubung secara "Connected Routes"

Router MikroTik-1 (1111:2222:3333:4444::1/64) :


Router MikroTik-2 (1111:2222:3333:4444::2/64) :


First Step Note:
- IPv6 Address bisa ditambahkan pada menu IPv6 ~> Address
- Itu kok ada 2 address lagi? itu addresss Link-Local (abaikan saja saat ini)

2. Pastikan sudah bisa PING dan pada IPv6 ~> Routes sudah terbentuk routing table DAC

Second Step Note:
- Status PING diperlihatkan dengan messages echo reply
- Routing Table IPv6 dapat dilihat dimenu IPv6 ~> Routes

3. Tambahkan Static Route pada Routing Table IPv6 ~> Routes

Router MikroTik-1 :
Gateway = 1111:2222:3333:4444::2
dst-address = ::/0


Router MikroTik-2 :
Gateway = 1111:2222:3333:4444::1
dst-address = ::/0

Third Step Note:
- Cara Masih Sama dengan static route pada IPv4 yang membedakan hanya IP yang digunakan
- ::/0 berarti default route (silahkan disesuaikan)
- IP Gateway adalah pintu masuk ke network tujuan/dst-address (sama seperti IPv4)

Untuk IP yang di route oleh MikroTik disini saya menggunakan IP Loopback, cara menambahkan IP Loopback adalah buatlah interface bridge tanpa ports dikedua router tersebut dan IP tersebut yang akan saya jadikan sebagai IP tujuan untuk di PING karena memang sudah beda network

Membuat Bridge Interface:


/interface bridge add name=lo
silahkan dilakukan dikedua router dan berikan IPv6 Address (There is no screenshoot, this is a challange for you as a readers)


Pengujian:

IPv6 beda network sudah bisa di PING !!!

Router MikroTik-1 Export Compact =
/interface bridge
add name=lo
/ipv6 address
add address=1111:2222:3333:4444::1 advertise=no interface=ether1
add address=2002::2 advertise=no interface=lo
/ipv6 route
add distance=1 gateway=1111:2222:3333:4444::2

Router MikroTik-2 Export Compact =
/interface bridge
add name=lo
/ipv6 address
add address=1111:2222:3333:4444::2 advertise=no interface=ether1
add address=2001::2 advertise=no interface=lo
/ipv6 route
add distance=1 gateway=1111:2222:3333:4444::1
Summary:
- Jujur saya masih pemula dalam IPv6 ini, pada awal mulanya saya diracunin sama mas Ikhwan untuk belajar IPv6 yang awalnya saya muak ngeliat deretan angka itu, tapi sejak diracunin dan dicoba ternyata asik juga, jadi mohon maaf jika masih salah menggunakan IPv6 Address karena saya rasa ini masih lingkup LAN jadi yowes hihihihi :D :D :D 
- dan tolong menu IPv4 dan IPv6 untuk melihat routing table, neighbor view, firewall itu beda menu hehehe
- lalu kenapa no-advertise? nah loh, itu PR untuk para pembaca :D we are not using SLAAC/RA here (maaf kalau salah)
- Tadinya mau nyobain OSPFv3 tapi bingung karena gak ada menu networks untuk advertise jadi yaudah deh, coba static route aja dulu :D dan googling juga masih bingung wkwkwkwkwk
- Config Static Route di IPv4 sama saja dengan IPv6, yang membedakan hanya pada address yang awalnya/biasanya menggunakan IPv4, sekarang kita ganti dengan IPv6
- And thanks to my IPv6 classmates and who was teach me IPv6

BGP Attribute & Path Selection

The Images Was Taken From Google Images
1. Overview
- Tiap routing protocol memiliki metric, RIP metricnya hop count, OSPF metricnya cost, EIGRP adalah bandwith dan delay
- Metric di BGP digunakan untuk menentukan best path selection algorithm
- BGP memiliki metric yang kompleks yang disebut dengan attribute
- BGP Origin adalah salah satu attribute yang menentukan best path selection algorithm
- Best path selection BGP ditentukan berdasarkan hirarki attribute dibawah ini:
01. Next-hop validation, next-hop active lebih prioritas dari unreachable
02. Distance, Prefer eBGP over iBGP
03. WEIGHT (default 0), semaking tinggi maka semakin prioritas
04. LOCAL-PREF (default 100), semakin tinggi maka semakin prioritas
05. Shortest AS-PATH, jalur AS terpendek
06. Locally originated path (aggregate, BGP network)
07. MED (default 0), terendah lebih prioritas
08. Prefer the route with lowest router ID or ORIGINATOR_ID
10. Shortest route reflection cluster (default 0)
11. Prefer the path that comes from lowest neighbor address

Secara umum BGP attribute terbagi menjadi dua, yaitu:
1. Well Known Attribute
Semua pabrikan perangkat merk apapun yang menjalankan BGP pasti mengenali dan memiliki atribute tipe ini, well known attribute terbagi menjadi dua, yaitu:
a. Mandatory (harus)
attribute ini pasti ada setiap kali router menjalankan BGP dan terbagi menjadi 3, yaitu:
- AS-Path : AS Number yang dilewati oleh BGP
- Next-hop : menampilkan ip via untuk menuju suatu route
- Origin : menampilkan informasi dari mana route berasal, apakah dari BGP atau IGP yang diredistribute ke BGP

b. Decretionary (bebas menentukan)
attribute ini baru ada apabila dikonfigurasikan, bila tidak dikonfigurasikan, maka attribute ini tidak dibawa serta oleh BGP dan terbagi menjadi 2, yaitu:
- Local Prefrence : digunakan untuk menentukan jalur upstream
- Automic Aggregate : merupakan suatu route hasil aggregate/summarization

2. Optional
Attribute ini hanya dimiliki oleh beberapa pabrikan tertentu saja, tidak semua perangkat yang menjalankan BGP mengenali dan memiliki fitur ini
Optional attribute terbagi menjadi dua, yaitu:
a. Transitive
Attribute ini apabila tidak dikenali oleh perangkat tertentu, maka attribute ini akan tetap diteruskan ke yang lainnya
1. Aggregator : merupakan router yang melakukan summarization
2. Community, terbagi menjadi 4:
- No-export : attribute ini akan menjadikan suatu route diadvertise hanya ke internal BGP saja
- No-advertise : attribute ini akan menjadikan suatu route tidak diadvertise kemana-mana, baik internal ataupun external
- Internet : attribute ini akan menjadikan route nya diadvertise kemana saja
- Local-as : attribute ini hanya ada pada BGP confederation, dimana routenya hanya akan diadvertise kedalam sub-as yang sama saja, tidak diadvertise ke sub AS yang lain

b. Non Transtive
Attribute ini apabila tidak dikenali oleh perangkat tertentu, maka akan didrop attributenya oleh perangkat tersebut
1. MED : digunakan untuk menentukan traffic kembali/downstream
2. Originator : menunjukan router yang menjadi route reflector
3. Cluster ID : menunjukan nilai cluster id yang digunakan pada redundant route reflector

Great Day with BPN : Interconnecting OSPF Network with BGP


08 Oktober 2016, Hari ini adalah hari yang cukup menyenangkan bagi saya dan setelah 2 tahun lamanya saya meng-update blog ini wkwkwkwkw

Hari ini saya belajar OSPF dan BGP dengan mas(ter) Rivaldo Ibrahim a.k.a Baim, mas(ter) Adit Ilhandi, mas(ter) Rifki a.k.a Bejo, mas(ter) Abdul Fatah, Memang sih awalnya saya dengan teman sekolah saya (aldi) datang dari SMK Taruna Bhakti Depok dan memiliki tujuan untuk Belajar Konsep dari NAT di BPN, namun disela waktu kosong kami mencoba config OSPF dan BGP pada Router MikroTik yang di gabungkan dengan Router Cisco 1841 untuk Internetworking-nya, Dan saya pun ingin mem-postingnya kedalam blog saya yang tidak update selama 2 tahun hehehe, sebenarnya scenarionya sih kita membuat Interconnection dengan BGP dan didalam AS itu ada OSPF Multi-Area (Standard, NSSA, Stub)

Jujur, ini pertama kalinya saya mencoba OSPF dan BGP pada Real Devices dan untuk Internetworking-nya saya menggabungkan Cisco 1841 (yang ditengah) dengan RB941-2n sebagai router yang meng-advertise prefix yang dimiliki dari AS100 dan AS200, Cisco 1841 sendiri memiliki AS150 yang digunakan hanya untuk transit eBGP dan setelah turun dari Router BGP masuk kedalam Router Gateway yang menggunakan RB951-2n dan menjalankan static route kearah Router BGP, NAT dan juga distribute default route untuk OSPF Area dibawahnya, setelah turun kebawah ada Router Distribusi yang terhubung dengan Not-So-Stubby-Area (NSSA) dan juga Stub Area, Kemudian didalam Router Gateway kami menjalankan Tunnel L2TP + IPSec agar kedua Local Area Network pada Stub Area bisa saling terhubung satu sama lain melalui Tunnel, tentu saja ditambahkan routing untuk kedua network tersebut, namun disini kami hanya menggunakan static route

Sebelumnya saya gambarkan menggunakan GNS3 untuk design topologi namun tidak untuk config, tapi tenang saja config + screenshot saya sertakan dibawah

1. R-BGP-100 as BGP Router AS100 (RB951-2n)
/routing bgp instance
set default as=100
/ip address
add address=110.110.110.1/30 interface=ether1 network=110.110.110.0
add address=11.11.11.1/30 interface=ether2 network=11.11.11.0
/routing bgp network
add network=11.11.11.0/30
add network=110.110.110.0/30
/routing bgp peer
add name=peer1 remote-address=110.110.110.2 remote-as=150
/system identity
set name=R-BGP-100
2. R-GW-100 as Gateway Router AS100 (RB951-2n)
/ip pool
add name=l2tp ranges=1.1.1.2-1.1.1.254
/ppp profile
set 1 local-address=1.1.1.1 remote-address=l2tp
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-2
/interface l2tp-server server
set enabled=yes ipsec-secret=123 use-ipsec=yes
/ip address
add address=11.11.11.2/30 interface=ether1 network=11.11.11.0
add address=10.10.10.1/30 interface=ether2 network=10.10.10.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/ip route
add distance=1 gateway=11.11.11.1
add distance=1 dst-address=192.168.2.0/24 gateway=1.1.1.254
/ppp secret
add name=l2tp password=123
/routing ospf network
add area=backbone network=10.10.10.0/30
/system identity
set name=R-GW-100
3. R-DIST-100 as Distribution Router AS100 (RB951-2n)
/routing ospf area
add area-id=0.0.0.1 default-cost=1 inject-summary-lsas=no name=area1 \
    translator-role=translate-never type=nssa
add area-id=0.0.0.2 default-cost=1 inject-summary-lsas=no name=area2 \
    translator-role=translate-never type=nssa
add area-id=0.0.0.10 default-cost=1 inject-summary-lsas=yes name=stub type=\
    stub
/ip address
add address=10.10.10.2/30 interface=ether1 network=10.10.10.0
add address=172.16.10.1/30 interface=ether2 network=172.16.10.0
add address=172.16.20.1/30 interface=ether3 network=172.16.20.0
add address=100.100.100.2/30 interface=ether4 network=100.100.100.0
/routing ospf network
add area=backbone network=10.10.10.0/30
add area=area2 network=172.16.20.0/30
add area=area1 network=172.16.10.0/30
add area=stub network=100.100.100.0/30
/system identity
set name=R-DIST-100
4. R-STUB-100 as Stub Area Router AS100 (RB750)
/ip pool
add name=dhcp_pool1 ranges=192.168.1.2-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether5 name=dhcp1
/routing ospf area
add area-id=0.0.0.10 inject-summary-lsas=yes name=stub type=\
    stub
/ip address
add address=100.100.100.1/30 interface=ether1 network=100.100.100.0
add address=192.168.1.1/24 interface=ether5 network=192.168.1.0
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1
/routing ospf network
add area=stub network=100.100.100.0/30
add area=stub network=192.168.1.0/24
/system identity
set name=R-STUB-100
5. R-NSSA-100-1 as NSSA Area-1 Router AS100 (RB941-2ND-TC)
/routing ospf area
add area-id=0.0.0.1 default-cost=1 inject-summary-lsas=no name=area1 type=nssa
/ip address
add address=172.16.10.2/30 interface=ether1 network=172.16.10.0
add address=100.100.100.1/30 interface=ether2 network=100.100.100.0
/routing ospf network
add area=area1 network=172.16.10.0/30
add area=area2 network=100.100.100.0/30
/system identity
set name=R-NSSA-1
6. R-NSSA-100-2 as NSSA Area-2 Router AS100 (RB941-2ND-TC)
/routing ospf area
add area-id=0.0.0.2 inject-summary-lsas=no name=area2 type=nssa
/ip address
add address=200.200.200.1/30 interface=ether2 network=200.200.200.0
add address=172.16.20.2/30 interface=ether1 network=172.16.20.0
/routing ospf network
add area=area2 network=172.16.20.0/30
add area=area1 network=200.200.200.0/30
/system identity
set name=R-NSSA-2

Cisco 1841 Configuration
  1. router bgp 150
  2.  neighbor 110.110.110.1 remote-as 100
  3.  neighbor 120.120.120.1 remote-as 200
  4.  no auto-summary


7. R-BGP-200 as BGP Router AS200 (RB951-2n)
/routing bgp instance
set default as=200
/ip address
add address=120.120.120.1/30 interface=ether1 network=120.120.120.0
add address=12.12.12.1/30 interface=ether2 network=12.12.12.0
/routing bgp network
add network=120.120.120.0/30
add network=12.12.12.0/30
/routing bgp peer
add name=peer1 remote-address=120.120.120.2 remote-as=150
/system identity
set name=R-BGP-200
 8. R-GW-200 as Gateway Router AS200 (RB951-2n)
/interface l2tp-client
add connect-to=11.11.11.2 disabled=no ipsec-secret=123 mrru=1600 name=\
    l2tp-out1 password=123 use-ipsec=yes user=l2tp
/routing ospf instance
set [ find default=yes ] distribute-default=always-as-type-2
/interface l2tp-server server
set ipsec-secret=123
/ip address
add address=12.12.12.2/30 interface=ether1 network=12.12.12.0
add address=20.20.20.1/30 interface=ether2 network=20.20.20.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/ip route
add distance=1 gateway=12.12.12.1
add distance=1 dst-address=192.168.1.0/24 gateway=1.1.1.1
/routing ospf network
add area=backbone network=20.20.20.0/30
/system identity
set name=R-GW-200
9.  R-DIST-200 as Distribution Router AS200 (RB951-2n)
/routing ospf area
add area-id=0.0.0.1 default-cost=1 inject-summary-lsas=no name=area1 \
    translator-role=translate-never type=nssa
add area-id=0.0.0.2 default-cost=1 inject-summary-lsas=no name=area2 \
    translator-role=translate-never type=nssa
add area-id=0.0.0.10 default-cost=1 inject-summary-lsas=yes name=stub type=stub
/ip address
add address=20.20.20.2/30 interface=ether1 network=20.20.20.0
add address=172.16.10.1/30 interface=ether2 network=172.16.10.0
add address=172.16.20.1/30 interface=ether3 network=172.16.20.0
add address=100.100.100.1/30 interface=ether4 network=100.100.100.0
/routing ospf network
add area=backbone network=20.20.20.0/30
add area=area1 network=172.16.10.0/30
add area=area2 network=172.16.20.0/30
add area=stub network=100.100.100.0/30
/system identity
set name=R-DIST-200
10. R-STUB-200 as Stub Area AS200 (RB951-2n)
/ip pool
add name=dhcp_pool1 ranges=192.168.2.2-192.168.2.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether5 name=dhcp1
/routing ospf area
add area-id=0.0.0.10 default-cost=1 inject-summary-lsas=yes name=stub \
    type=stub
/ip address
add address=100.100.100.2/30 interface=ether1 network=100.100.100.0
add address=192.168.2.1/24 interface=ether5 network=192.168.2.0
/ip dhcp-server network
add address=192.168.2.0/24 gateway=192.168.2.1
/routing ospf network
add area=stub network=100.100.100.0/30
add area=stub network=192.168.2.0/24
/system identity
set name=R-STUB-200 

11. R-NSSA-200-1 as NSSA Area-1 AS200 (RB941-2ND-TC)
/routing ospf area
add area-id=0.0.0.1 default-cost=1 inject-summary-lsas=no name=area1 \
    translator-role=translate-never type=nssa
/ip address
add address=172.16.10.2/30 interface=ether1 network=172.16.10.0
/routing ospf network
add area=area1 network=172.16.10.0/30
/system identity
set name=R-NSSA-1
12. R-NSSA-200-2 as NSSA Area-2 AS200 (RB941-2ND-TC)
/routing ospf area
add area-id=0.0.0.2 default-cost=1 inject-summary-lsas=no name=area2 \
    translator-role=translate-never type=nssa
/ip address
add address=172.16.20.2/30 interface=ether1 network=172.16.20.0
/routing ospf network
add area=area2 network=172.16.20.0/30
/system identity
set name=R-NSSA-2

Sekian configuration yang saya buat dengan teman teman di Best-Path Networks, Mohon maaf jika ada kesalahan konfigurasi, namun sudah kami coba dan berhasil :) mohon maaf juga untuk tuan rumah karena saya OOT dari tujuan awal hehehe, dan dibawah ini ada beberapa dokumentasi yang saya kumpulkan :D





















Pantang Pulang, Sebelum PING Reply
Sekian & Terima Kasih :D